aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorTom Ryder <tom@sanctum.geek.nz>2017-10-03 15:13:57 +1300
committerTom Ryder <tom@sanctum.geek.nz>2017-10-03 15:21:57 +1300
commit65a54c00d8083a96c18f02b7f43a4822e3f1fd9a (patch)
tree09b826ca77ccd7b9aad4cf830ff156eea8799499 /Makefile.PL
downloadList-Breakdown-65a54c00d8083a96c18f02b7f43a4822e3f1fd9a.tar.gz (sig)
List-Breakdown-65a54c00d8083a96c18f02b7f43a4822e3f1fd9a.zip
First commit of List::Filtersv0.01
I'll add more Perl distribution infrastructure and tests as I learn more about how that all works. The README.markdown is just a manually converted README for now.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..54aef50
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,23 @@
+use 5.006;
+use strict;
+use warnings;
+use ExtUtils::MakeMaker;
+
+WriteMakefile(
+ NAME => 'List::Filters',
+ AUTHOR => 'Tom Ryder <tom@sanctum.geek.nz>',
+ VERSION_FROM => 'lib/List/Filters.pm',
+ ABSTRACT_FROM => 'lib/List/Filters.pm',
+ LICENSE => 'artistic_2',
+ PL_FILES => {},
+ MIN_PERL_VERSION => '5.006',
+ CONFIGURE_REQUIRES => {
+ 'ExtUtils::MakeMaker' => '0',
+ },
+ BUILD_REQUIRES => {
+ 'Test::More' => '0',
+ },
+ PREREQ_PM => {},
+ dist => { COMPRESS => 'gzip -9f', SUFFIX => 'gz', },
+ clean => { FILES => 'List-Filters-*' },
+);