aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL12
1 files changed, 9 insertions, 3 deletions
diff --git a/Makefile.PL b/Makefile.PL
index fd5e553..f863b1d 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -4,6 +4,7 @@ use warnings;
use ExtUtils::MakeMaker;
WriteMakefile(
+ (MM->can('signature_target') ? (SIGN => 1) : ()),
NAME => 'List::Breakdown',
AUTHOR => 'Tom Ryder <tom@sanctum.geek.nz>',
VERSION_FROM => 'lib/List/Breakdown.pm',
@@ -22,15 +23,20 @@ WriteMakefile(
'Exporter' => '0',
},
META_MERGE => {
+ 'meta-spec' => { version => 2 },
provides => {
'List::Breakdown' => {
- version => '0.19',
+ version => '0.26',
file => 'lib/List/Breakdown.pm',
},
},
resources => {
- homepage => 'https://sanctum.geek.nz/cgit/List-Breakdown.git/',
- repository => 'https://sanctum.geek.nz/code/List-Breakdown.git/',
+ homepage => 'https://dev.sanctum.geek.nz/cgit/List-Breakdown.git/',
+ repository => {
+ type => 'git',
+ url => 'https://dev.sanctum.geek.nz/code/List-Breakdown.git/',
+ web => 'https://dev.sanctum.geek.nz/cgit/List-Breakdown.git/',
+ },
},
},
dist => { COMPRESS => 'gzip -9f', SUFFIX => 'gz', },