aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Ryder <tom@sanctum.geek.nz>2018-08-21 14:14:41 +1200
committerTom Ryder <tom@sanctum.geek.nz>2018-08-21 14:14:41 +1200
commit8802414345b8f6656f6455431b8a56aa40db0ee0 (patch)
tree748105f13738851ba659eb265dc219304d2b5ffd
parent39bac9a74ebaaf6e1ee6fc2c51cda9c640498d93 (diff)
parent6c42dee2e83f3a2790252f079f47301047e7f848 (diff)
downloaddotfiles-1.56.0.tar.gz (sig)
dotfiles-1.56.0.zip
Merge branch 'release/v1.56.0'v1.56.0
* release/v1.56.0: Bump VERSION Don't clear away g:loaded_gzip Add option terminators or equivs to :compilers Revert "Let's try leaving netrw on again for a ...
-rw-r--r--VERSION4
-rw-r--r--vim/after/plugin/dist.vim2
-rw-r--r--vim/compiler/bash.vim4
-rw-r--r--vim/compiler/ksh.vim4
-rw-r--r--vim/compiler/perlcritic.vim4
-rw-r--r--vim/compiler/php.vim4
-rw-r--r--vim/compiler/sh.vim4
-rw-r--r--vim/compiler/shellcheck.vim4
-rw-r--r--vim/compiler/vint.vim4
-rw-r--r--vim/compiler/zsh.vim4
-rw-r--r--vim/plugin/dist.vim2
11 files changed, 21 insertions, 19 deletions
diff --git a/VERSION b/VERSION
index 53854eb4..487f6508 100644
--- a/VERSION
+++ b/VERSION
@@ -1,2 +1,2 @@
-tejr dotfiles v1.55.0
-Thu Aug 16 11:28:48 UTC 2018
+tejr dotfiles v1.56.0
+Tue Aug 21 02:14:41 UTC 2018
diff --git a/vim/after/plugin/dist.vim b/vim/after/plugin/dist.vim
index bc8995b6..f7491d66 100644
--- a/vim/after/plugin/dist.vim
+++ b/vim/after/plugin/dist.vim
@@ -2,8 +2,8 @@
unlet! g:loaded_getscriptPlugin
unlet! g:loaded_vimballPlugin
unlet! g:loaded_logiPat
+unlet! g:loaded_netrwPlugin
unlet! g:loaded_rrhelper
unlet! g:loaded_spellfile_plugin
-unlet! g:loaded_gzip
unlet! g:loaded_tarPlugin
unlet! g:loaded_zipPlugin
diff --git a/vim/compiler/bash.vim b/vim/compiler/bash.vim
index 70997f92..832e9120 100644
--- a/vim/compiler/bash.vim
+++ b/vim/compiler/bash.vim
@@ -10,8 +10,8 @@ endif
" 7.4.191 is the earliest version with the :S file name modifier, which we
" really should use if we can
if v:version >= 704 || v:version == 704 && has('patch191')
- CompilerSet makeprg=bash\ -n\ %:S
+ CompilerSet makeprg=bash\ -n\ --\ %:S
else
- CompilerSet makeprg=bash\ -n\ %
+ CompilerSet makeprg=bash\ -n\ --\ %
endif
CompilerSet errorformat=%f:\ line\ %l:\ %m
diff --git a/vim/compiler/ksh.vim b/vim/compiler/ksh.vim
index 1b31ffa7..be552972 100644
--- a/vim/compiler/ksh.vim
+++ b/vim/compiler/ksh.vim
@@ -10,8 +10,8 @@ endif
" 7.4.191 is the earliest version with the :S file name modifier, which we
" really should use if we can
if v:version >= 704 || v:version == 704 && has('patch191')
- CompilerSet makeprg=ksh\ -n\ %:S
+ CompilerSet makeprg=ksh\ -n\ --\ %:S
else
- CompilerSet makeprg=ksh\ -n\ %
+ CompilerSet makeprg=ksh\ -n\ --\ %
endif
CompilerSet errorformat=%f:\ %l:\ %m
diff --git a/vim/compiler/perlcritic.vim b/vim/compiler/perlcritic.vim
index 03d21683..0d61487b 100644
--- a/vim/compiler/perlcritic.vim
+++ b/vim/compiler/perlcritic.vim
@@ -10,8 +10,8 @@ endif
" 7.4.191 is the earliest version with the :S file name modifier, which we
" really should use if we can
if v:version >= 704 || v:version == 704 && has('patch191')
- CompilerSet makeprg=perlcritic\ --verbose\ 1\ %:S
+ CompilerSet makeprg=perlcritic\ --verbose\ 1\ --\ %:S
else
- CompilerSet makeprg=perlcritic\ --verbose\ 1\ %
+ CompilerSet makeprg=perlcritic\ --verbose\ 1\ --\ %
endif
CompilerSet errorformat=%f:%l:%c:%m
diff --git a/vim/compiler/php.vim b/vim/compiler/php.vim
index aeb171c5..2d5f4f69 100644
--- a/vim/compiler/php.vim
+++ b/vim/compiler/php.vim
@@ -10,9 +10,9 @@ endif
" 7.4.191 is the earliest version with the :S file name modifier, which we
" really should use if we can
if v:version >= 704 || v:version == 704 && has('patch191')
- CompilerSet makeprg=php\ -lq\ %:S
+ CompilerSet makeprg=php\ -lq\ -f\ %:S
else
- CompilerSet makeprg=php\ -lq\ %
+ CompilerSet makeprg=php\ -lq\ -f\ %
endif
" Here be copy-pasted dragons
diff --git a/vim/compiler/sh.vim b/vim/compiler/sh.vim
index ff5ed314..a62a00db 100644
--- a/vim/compiler/sh.vim
+++ b/vim/compiler/sh.vim
@@ -10,8 +10,8 @@ endif
" 7.4.191 is the earliest version with the :S file name modifier, which we
" really should use if we can
if v:version >= 704 || v:version == 704 && has('patch191')
- CompilerSet makeprg=sh\ -n\ %:S
+ CompilerSet makeprg=sh\ -n\ --\ %:S
else
- CompilerSet makeprg=sh\ -n\ %
+ CompilerSet makeprg=sh\ -n\ --\ %
endif
CompilerSet errorformat=%f:\ %l:\ %m
diff --git a/vim/compiler/shellcheck.vim b/vim/compiler/shellcheck.vim
index 6d6498da..354291f6 100644
--- a/vim/compiler/shellcheck.vim
+++ b/vim/compiler/shellcheck.vim
@@ -20,8 +20,8 @@ endif
" 7.4.191 is the earliest version with the :S file name modifier, which we
" really should use if we can
if v:version >= 704 || v:version == 704 && has('patch191')
- execute s:set . '\ %:S'
+ execute s:set . '\ --\ %:S'
else
- execute s:set . '\ %'
+ execute s:set . '\ --\ %'
endif
CompilerSet errorformat=%f:%l:%c:\ %m\ [SC%n]
diff --git a/vim/compiler/vint.vim b/vim/compiler/vint.vim
index 54d0fc4d..db75d3c6 100644
--- a/vim/compiler/vint.vim
+++ b/vim/compiler/vint.vim
@@ -10,8 +10,8 @@ endif
" 7.4.191 is the earliest version with the :S file name modifier, which we
" really should use if we can
if v:version >= 704 || v:version == 704 && has('patch191')
- CompilerSet makeprg=vint\ %:S
+ CompilerSet makeprg=vint\ --\ %:S
else
- CompilerSet makeprg=vint\ %
+ CompilerSet makeprg=vint\ --\ %
endif
CompilerSet errorformat=%f:%l:%c:\ %m
diff --git a/vim/compiler/zsh.vim b/vim/compiler/zsh.vim
index 685a01ad..c9290b8d 100644
--- a/vim/compiler/zsh.vim
+++ b/vim/compiler/zsh.vim
@@ -10,8 +10,8 @@ endif
" 7.4.191 is the earliest version with the :S file name modifier, which we
" really should use if we can
if v:version >= 704 || v:version == 704 && has('patch191')
- CompilerSet makeprg=zsh\ -n\ %:S
+ CompilerSet makeprg=zsh\ -n\ --\ %:S
else
- CompilerSet makeprg=zsh\ -n\ %
+ CompilerSet makeprg=zsh\ -n\ --\ %
endif
CompilerSet errorformat=%f:%l:\ %m
diff --git a/vim/plugin/dist.vim b/vim/plugin/dist.vim
index 37fc9042..f9cc6d18 100644
--- a/vim/plugin/dist.vim
+++ b/vim/plugin/dist.vim
@@ -7,6 +7,8 @@ let g:loaded_tarPlugin = 1
let g:loaded_zipPlugin = 1
" I prefer filtering text with Unix tools
let g:loaded_logiPat = 1
+" The shell, tab completion, and 'wildmenu' are good enough
+let g:loaded_netrwPlugin = 1
" I don't use Vim servers
let g:loaded_rrhelper = 1
" I don't need extra spelling files