aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorTom Ryder <tom@sanctum.geek.nz>2017-10-05 17:04:35 +1300
committerTom Ryder <tom@sanctum.geek.nz>2017-10-05 17:04:35 +1300
commit1cd8d85025254f2069416e05b762e3a4ee63ee5e (patch)
tree54a689d5461ae5145fe90dbdc9b84039c003867f /Makefile.PL
parentRemove croncryptsh (diff)
downloadMail-Run-Crypt-1cd8d85025254f2069416e05b762e3a4ee63ee5e.tar.gz
Mail-Run-Crypt-1cd8d85025254f2069416e05b762e3a4ee63ee5e.zip
Add Module::Starter boilerplate for perlmodding
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL26
1 files changed, 26 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..91827fc
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,26 @@
+use 5.006;
+use strict;
+use warnings;
+use ExtUtils::MakeMaker;
+
+WriteMakefile(
+ NAME => 'Mail::Cron::Crypt',
+ AUTHOR => q{Tom Ryder <tom@sanctum.geek.nz>},
+ VERSION_FROM => 'lib/Mail/Cron/Crypt.pm',
+ ABSTRACT_FROM => 'lib/Mail/Cron/Crypt.pm',
+ LICENSE => 'artistic_2',
+ PL_FILES => {},
+ MIN_PERL_VERSION => '5.006',
+ CONFIGURE_REQUIRES => {
+ 'ExtUtils::MakeMaker' => '0',
+ },
+ BUILD_REQUIRES => {
+ 'Test::More' => '0',
+ },
+ PREREQ_PM => {
+ #'ABC' => '1.6',
+ #'Foo::Bar::Module' => '5.0401',
+ },
+ dist => { COMPRESS => 'gzip -9f', SUFFIX => 'gz', },
+ clean => { FILES => 'Mail-Cron-Crypt-*' },
+);