aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorTom Ryder <tom@sanctum.geek.nz>2020-04-25 04:23:50 +1200
committerTom Ryder <tom@sanctum.geek.nz>2020-04-25 04:23:50 +1200
commit631f9c99d90c2f79e094cb25e99ff048e6c54d82 (patch)
treefd0b6b68a368fe53af77979635d4a5acf78856f6 /Makefile.PL
downloadnagios-check-mount-631f9c99d90c2f79e094cb25e99ff048e6c54d82.tar.gz
nagios-check-mount-631f9c99d90c2f79e094cb25e99ff048e6c54d82.zip
Version 1.00v1.00
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL38
1 files changed, 38 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..9aa45d1
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,38 @@
+use 5.006;
+use strict;
+use warnings;
+use ExtUtils::MakeMaker;
+
+WriteMakefile(
+ NAME => 'check_mount',
+ AUTHOR => 'Tom Ryder <tom@sanctum.geek.nz>',
+ VERSION_FROM => 'libexec/check_mount',
+ LICENSE => 'MIT',
+ INSTALLSCRIPT => '/usr/local/nagios/libexec',
+ INSTALLSITESCRIPT => '/usr/local/nagios/libexec',
+ EXE_FILES => ['libexec/check_mount'],
+ MIN_PERL_VERSION => '5.010_001',
+ CONFIGURE_REQUIRES => {
+ 'ExtUtils::MakeMaker' => '0',
+ },
+ PREREQ_PM => {
+ 'English' => 0,
+ 'Exception::Class' => 0,
+ 'Monitoring::Plugin' => 0,
+ 'Path::Tiny' => 0,
+ 'Quota' => 0,
+ 'Try::Tiny' => 0,
+ },
+ META_MERGE => {
+ 'meta-spec' => { version => 2 },
+ resources => {
+ homepage => 'https://sanctum.geek.nz/cgit/check_mount.git/',
+ repository => {
+ type => 'git',
+ url => 'https://sanctum.geek.nz/code/check_mount.git/',
+ web => 'https://sanctum.geek.nz/cgit/check_mount.git/',
+ },
+ },
+ },
+ clean => { FILES => 'check_mount-*' },
+);