aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorTom Ryder <tom@sanctum.geek.nz>2017-10-05 18:06:47 +1300
committerTom Ryder <tom@sanctum.geek.nz>2017-10-05 19:32:42 +1300
commit7969bce43d9c445d87a68080587298728d0d3e38 (patch)
tree6b0564dda9aecf08e3d465e4c52efb13984af419 /Makefile.PL
parentAdd Module::Starter boilerplate for perlmodding (diff)
downloadMail-Run-Crypt-7969bce43d9c445d87a68080587298728d0d3e38.tar.gz
Mail-Run-Crypt-7969bce43d9c445d87a68080587298728d0d3e38.zip
Rename/separate out into app and module
This still needs a lot more work before release. In particular, I have to figure out what I'm going to do about the `passphrase` option. It's probably better to both not require it, in which case no signing is done (only encryption), and to instead allow a path to a file to be specified. The other big puzzle would be how on earth to write automated tests for it... I may end up imitating however Mail::GnuPG is testing itself.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 91827fc..299a4b6 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -4,10 +4,10 @@ use warnings;
use ExtUtils::MakeMaker;
WriteMakefile(
- NAME => 'Mail::Cron::Crypt',
+ NAME => 'Mail::Run::Crypt',
AUTHOR => q{Tom Ryder <tom@sanctum.geek.nz>},
- VERSION_FROM => 'lib/Mail/Cron/Crypt.pm',
- ABSTRACT_FROM => 'lib/Mail/Cron/Crypt.pm',
+ VERSION_FROM => 'lib/Mail/Run/Crypt.pm',
+ ABSTRACT_FROM => 'lib/Mail/Run/Crypt.pm',
LICENSE => 'artistic_2',
PL_FILES => {},
MIN_PERL_VERSION => '5.006',
@@ -21,6 +21,7 @@ WriteMakefile(
#'ABC' => '1.6',
#'Foo::Bar::Module' => '5.0401',
},
+ EXE_FILES => ['bin/runcrypt'],
dist => { COMPRESS => 'gzip -9f', SUFFIX => 'gz', },
- clean => { FILES => 'Mail-Cron-Crypt-*' },
+ clean => { FILES => 'Mail-Run-Crypt-*' },
);